Documentation

Справка по программе работа с матрицами 3 на 3.

Программа предназначена для детей и подростков, учащихся школ и вузов по

специальности математика.

Основные возможности программы.

  1. Вычисление арифметических выражений, включающий полный набор всех математических функций.
  2. Сложение, скалярное произведение и умножение векторов на число
  3. Сложение, перемножение и умножение матриц на число, вектор,матрицу.
  4. Для скаляров вычисление расстояния между двумя векторами
  5. Для векторов нормализация вектора, длинна вектора, обратный вектор. Три вида интерполяции двух векторов кривой содержащей заданные векторы. Линейная - интерполяция прямой и две интерполяции кривыми: CatmullRom и Эрмитова интерполяция, данные кривые задаются помимо двух векторов двумя касательными векторами. Барицентр трёх векторов с графическим представлением и панелью управления картинки. Смешанное произведение двух векторов, т.е. вектор пенпендикулярный заданным двум. Отсечение вектора двумя векторами снизу и сверху, покоординатно. Максимум двух векторов покоординатно. Отражение вектора от поверхности заданной вектором нормали с графической картинкой и управлением ею.
  6. Для матриц нулевая, единичная матрица, вектора верха, переда, зада, низа и левый и правый вектора матрицы, вычисление детерминанта матрицы, обратной матрицы и транспонирование матрицы, матрица вращения вокруг произвольной оси заданной вектором и видовая матрица, заданная тремя векторами представляющими собой видео камеру.

Все вычисления в программе происходят численно, а не аналитически.

аналитически возможен только ввод числа.


Font

Шрифт

Всегда нажав кнопку шрифт вы можете поменять размер надписей и шрифт сразу

во всех окнах программы.


ToolTip

Всплывающие подсказки

Каждый оператор умножения или сложения, а также кнопки равенства

снабжены всплывающими подсказками.

Например - здесь происходит скалярное умножение векторов,

или здесь вектор умножается на матрицу или складываются две матрицы


Context Menu

Контекстные меню

Основная часть работы в программе происходит через контекстные меню.

Для матриц вызывается своё контекстное меню и при нажатии выбора из

списка открывается новое окно или MessageBox например с вычисленным

детерминантом матрицы или считается обратная матрица.

Для векторов своё контекстное меню с интерполяцией и барицентром

А для чисел своё контекстное меню. Любое аналитически заданное число можно

вычислить через контекстное меню.


Animation

Анимация

Во время вычислений происходит небольшая анимация чисел,

числа в течении 5-ти секунд хаотично меняются и затем в матрице или векторе

появляется вычисленное значение.


FichaDragAndDrop

Утилита DragAndDrop

Все числа, вектора и матрицы можно перетаскивать мышкой друг в друга,

и таки способом осуществлять копирование.

А точнее числовые поля в числовые,

вектора в вектора и

матрицы в матрицы.

Причём вы можете копировать числа и матрицы из одного окна в другое.


AboutProgram

Кнопка о программе

Нажав эту кнопку вы познакомитесь со мною и сможете прямо из программы посетить мой форум. Я его регулярно просматриваю и отвечаю на вопросы по

моим программам. Там так-же есть много интересного, например помимо математики и программирования я также рисую в 3d и делаю мультики и компьютерные игры.


ScreenShoot

Скриншоты программы


Enter

Введение

Для аналитического ввода чисел в программу используется визуальный AriphmeticalTextBoxWithWarning

Он выглядит, как обычный TextBox, только хранит в себе введённое арифметическое выражение. число в него вводится по правилам арифметики. Если число было введено с ошибкой то появится всплывающая подсказка, как нужно правильно ввести число. Например скажет, что была не закрыта скобка или происходит деление на ноль. Все вектора в программе и матрицы сконструированны при помощи его. Если арифметическое выражение было введено в числовое поле правильно, то появится всплывающая подсказка, что

"Анализ прошёл успешно "

Картинка


Function

Функции и операторы

Числа

Чтобы ввести в программу десятичную и сотую и т.д. часть числа используется

для этих целей запятая

Например 0,5 или 78,902

Плюс ещё возможен ввод научной формы записи числа

Например 1,67e+4

Так же для работы с тригонометрическими функциями в программу специально

введено число Pi=3,14... половина длинны окружности единичного радиуса -

иррациональное число.

И число E = 2,71828182845905 значение экспоненты от 1

Операторы

Для ввода чисел в числовой TextBox используется следующие операторы

+ сложение

- вычитание

* умножение

/ деление, делить на ноль естественно нельзя

^ (крышечка на клавиатуре) возведение в степень, возводить в степень можно

не только натуральные числа 2^2=4 но и вещественные 4^0,5 =2 и даже

отрицательные 5^-3=1/5^3, единственное что запрещено возводить

отрицательное число в рациональное, классическим примером этому в

математике служит корень из -1 т.е. (-1)^0,5 хотя (-1)^(1/3)=-1

а точнее если мы возводим отрицательное вещественное число в

рациональное a/b, так вот если b четное, то степень не извлекается, если b

нечётное, то степень извлекается. Возведение отрицательного вещественного

числа в иррациональное число математике неизвестно. А моей программой

возведение отрицательного числа в рациональное не предусмотрено, только в

целое. Так же хочу добавить, что в программе бинарный оператор ^ не

ассоциативен.

Функции

Программа поддерживает все стандартные функции математики,

а именно:

sin синус

cos косинус

tg тангенс

ctg катангенс

arctg арктангенс

arcctg арккатангенс

arcsin арксинус

arccos арккосинус

exp экспонента

ln натуральный логарифм

sqrt корень квадратный

abs модуль